Script för dynamisk dns med Mikrotik router

Lopdns anpassat script från wiki.mikrotik.com

Byt ut ddnsuser variablen till första delen av din dynamiska nyckel som du får när du gjort ett dynamiskt hostnamn.

Byt ut ddnspass variablen till andra delen av din dynamiska nyckel.

I exemplet används den dynamiska nyckeln: E3680031-6176-4F77-B8CE-EA5A7A67A702 som vi fick för värdnamnet dynamiskdemo.lopdns.se

1) add a script called dynDNS:

# Define User Variables
:global ddnsuser "E3680031-6176-4F77"
:global ddnspass "B8CE-EA5A7A67A702"
:global ddnshost "dynamiskdemo.lopdns.se"

# Define Global Variables
:global ddnsip
:global ddnslastip
:if ([ :typeof $ddnslastip ] = nil ) do={ :global ddnslastip "0" }

:global ddnsinterface
:global ddnssystem ("mt-" . [/system package get system version] )

# Define Local Variables
:local int

# Loop thru interfaces and look for ones containing
# default gateways without routing-marks
:foreach int in=[/ip route find dst-address=0.0.0.0/0 active=yes ] do={
  :if ([:typeof [/ip route get $int routing-mark ]] != str ) do={
     :global ddnsinterface [/ip route get $int interface]
  }
}

# Grab the current IP address on that interface.
:global ddnsip [ /ip address get [/ip address find interface=$ddnsinterface ] address ]

# Did we get an IP address to compare?
:if ([ :typeof $ddnsip ] = nil ) do={
   :log info ("DynDNS: No ip address present on " . $ddnsinterface . ", please check.")
} else={
  :if ($ddnsip != $ddnslastip) do={
    :log info "DynDNS: Sending UPDATE!"
    :local str "/nic/update?hostname=$ddnshost&myip=$ddnsip&wildcard=NOCHG&mx=NOCHG&backmx=NOCHG"
    /tool fetch address=dyn.i8t.com src-path=$str mode=https user=$ddnsuser \
        password=$ddnspass dst-path=("/DynDNS.".$ddnshost)
    :delay 1
    :local str [/file find name="DynDNS.$ddnshost"];
    /file remove $str
    :global ddnslastip $ddnsip
  }
}

2) Add a scheduler entry to run every minute

/system scheduler add name=dynDNS interval=00:01 on-event="/system script run dynDns\r\n"
Har du fler frågor? Skicka en förfrågan

0 Kommentarer

logga in för att lämna en kommentar.
Powered by Zendesk